tiamaressp035gw
17.04.2022 22:31

Составить программу для нахождения суммы по следующей формуле паскаль 9 класс​​


Составить программу для нахождения суммы по следующей формуле паскаль 9 класс​​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
анастасиятихая
29.07.2020 21:28

case <выражение-селектор > of <список значений1>: <оператор1;> <список значений 2>: <оператор2;> … <список значений N>: <операторN> else<оператор> end;

Program Number1; Var   a : integer; Begin   writeln('Введите цифру ');   readln(a);   if (a<0) or (a>9)     then       writeln ('Это число не является цифрой')     else       case a of         0 : writeln ('ноль');         1 : writeln ('один');         2 : writeln ('два');         3 : writeln ('три');         4 : writeln ('четыре');       end;   readln; End.


Запишите общий вид оператора выбора.
0,0(0 оценок)
Ответ:
МарияПу16
14.09.2021 05:44

8 LLLVR

81 L

98 RLRVR

110 RRLLR

179 VLRVR

Объяснение:

Я написал код, могу им поделиться. Его можно было бы еще упростить, ну я не стал, и так нормально.

Чтобы написать решение задачи можно идти снизу вверх. Точнее я не вижу легче. То есть, сначала мы будем рассматривать случай когда только две буквы(как раз последние две). Мы их изменяем от LL до VV. Потом мы меняем третью букву и снова по кругу (меняем снова последние две). После того, как дошли до VV, мы меняем третью букву на следующую и возвращаем последние две буквы в начальное положение. Так и продолжаем, идем по кругу с четвертой буквой, и так далее.

Код был написан на Python, если не разбираетесь то немного объясню, def - это функция(хотя почти везде это так); переменная glob - хранит текущий порядок, то есть на каком числе остановился.

def men(buk) - это функция нужна чтобы упростить жизнь, то есть чтобы каждый раз не писать: если эта буква L, меняем её на R и так далее. Основные моменты я объяснил. Я закину и код, и результат, если ты не можешь запустить этот код. Круглые скобки - это кортеж(что такое, объяснять не буду)) не это цель ответа).

оцени как лучший ответ, впервые написал такой большой ответ)), если не жалко конечно))

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота