Araikavipv
12.06.2022 12:19

40 написать программу кол - во трёхзначных чисел кратных 4 вот числа 4 44, 444, 4444, 44444 - паскаль

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
emeli2007
15.08.2020 09:16
Const
    n = 25;

var
    a: array[1..n] of real;
    i, j: integer;
    min, max: real;
    sum, product, harmonic: real;

begin
    {ввод массива}
    writeln('Данные массива:');
    for i := 1 to n do
    begin
        a[i] := random(40) - 20;
        write(a[i], ' ');
    end;
    writeln();
    
    {подсчет суммы и произведения и агригатов}
    sum := 0;
    for i := 1 to n do
        sum := sum + a[i];
    writeln('average = ', sum / n);
    
    {минимум и максимум}
    min := a[1];
    for i := 1 to n do
        if min > a[i] then min := a[i];
    writeln('min = ', min);
    
    {подсчет суммы и произведения и агригатов}
    sum := 0;
    for i := 1 to n do
        if i mod 2 = 0 then {если нужен фильтр}
            sum := sum + a[i];
    writeln('sum = ', sum);
end.
0,0(0 оценок)
Ответ:
Гриша2148139
23.08.2021 21:35

Program Scheme;

Var xn,xk,dx,x,s,p,k,y: Extended;

Label rep;

Begin

write('Enter xn: ');

readln(xn);

write('Enter xk: ');

readln(xk);

write('Enter dx: ');

readln(dx);

s:=0; p:=1; x:=xn; k:=0;

rep:

If x <= xk then

 Begin

  y:=exp(sin(x))*cos(x);

  writeln('x = ',x:0:3, '  y = ', y:0:3);

  if y >= 0 then

  s:=s+y;

  if y <> 0 then

  p:=p*y;

  x:=x+dx;

  goto rep;

 End

else

 Begin

  writeln('S = ', s:0:3, ' P = ', p:0:3, ' k = ', k:0:3);

  exit;

 End;

End.

Объяснение: Если есть вопросы, пишите в лс.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота