(НА СИ++) Составить программу для вычисления одной из указанных ниже функций в соответствии с заданным вариантом.
Программа должна запрашивать с клавиатуры значение аргумента и выводить на экран результат.
Функции, используемые в формуле, нужно предварительно заменить тождественными выражениями из библиотечных функций. При подборе тестовых значений аргумента учитывайте область определения каждой функции, входящей в формулу


(НА СИ++) Составить программу для вычисления одной из указанных ниже функций в соответствии с заданн

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
анна2246
03.09.2022 05:18
Var
 A:array[1..4] of integer;
 i,j,R,P:integer;
function HOD(c,b:integer):integer;
 begin
  while c<>b do
   if c>b
     then
      c:=c-b
    else
     b:=b-c;
  HOD:=c;
 end;
function HOK(c,b, RR:integer):integer;
 begin
  if ((c mod b=0) or (b mod c=0)) and ((c div b > 1) or (b div c > 1))
   then
     begin
       if c>b
          then
           HoK:=c
         else
          HOK:=b;
     end
    else
     HOK:=(c*b) div RR;
 end;
begin
 A[1]:=36;
 A[2]:=54;
 A[3]:=18;
 A[4]:=15;
 P:=1;
 R:=HOD(A[1],A[2]);
 P:=HOK(A[1], A[2], R);
 for i:=3 to 4 do
  begin
   R:=HOD(R, A[i]);
   P:=HOK(P, A[i],R);
  end; writeln('HOK = ',P);
end.
0,0(0 оценок)
Ответ:
Svoyaya
03.09.2022 05:18
Var
 A:array[1..4] of integer;
 i,j,R,P:integer;
function HOD(c,b:integer):integer;
 begin
  while c<>b do
   if c>b
     then
      c:=c-b
    else
     b:=b-c;
  HOD:=c;
 end;
function HOK(c,b, RR:integer):integer;
 begin
  if ((c mod b=0) or (b mod c=0)) and ((c div b > 1) or (b div c > 1))
   then
     begin
       if c>b
          then
           HoK:=c
         else
          HOK:=b;
     end
    else
     HOK:=(c*b) div RR;
 end;
begin
 A[1]:=36;
 A[2]:=54;
 A[3]:=18;
 A[4]:=15;
 P:=1;
 R:=HOD(A[1],A[2]);
 P:=HOK(A[1], A[2], R);
 for i:=3 to 4 do
  begin
   R:=HOD(R, A[i]);
   P:=HOK(P, A[i],R);
  end; writeln('HOK = ',P);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота