Mahaeva33
18.01.2023 11:29

Напишите программу на языке JavaScript, которая будет рассчитывать потенциальную энергию по формуле: Eп=mgh. Данные должны вводиться заранее с клавиатуры. Необходимо учитывать, что g – ускорение свободного падения (постоянная величина). В случае не ввода данных или при вводе не числовых значений, должны выводиться сообщения об ошибке. Результат вывести на зеленом фоне с выравниванием по левому краю. Добавить кнопку, которая будет перезапускать программу и ссылку, которая будет изменять цвет фона на красный.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
GRISHINANASTYA
19.03.2021 01:01
Написали бы язык программирования. Вот на java.
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;


public class znanie {
public static void main(String[] args) throws IOException {
BufferedReader reader=new BufferedReader(new InputStreamReader(System.in));
long A=Long.parseLong(reader.readLine());
long B=Long.parseLong(reader.readLine());
if((A<0)||(B<0)){
System.exit(0);
}
long sum=0;
for (long i = A; i <= B; i++) {
if((i%5==0)||(i%13==0)){
sum=sum+i;
}
}
System.out.println(sum);
}
}
0,0(0 оценок)
Ответ:
marikalinich
19.03.2021 01:01
Написали бы язык программирования. Вот на java.
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;


public class znanie {
public static void main(String[] args) throws IOException {
BufferedReader reader=new BufferedReader(new InputStreamReader(System.in));
long A=Long.parseLong(reader.readLine());
long B=Long.parseLong(reader.readLine());
if((A<0)||(B<0)){
System.exit(0);
}
long sum=0;
for (long i = A; i <= B; i++) {
if((i%5==0)||(i%13==0)){
sum=sum+i;
}
}
System.out.println(sum);
}
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота