sohibjamol2008
03.12.2022 16:24

Дан массив a, состоящий из n целых чисел. Ваша задача — переписать его элементы в другой массив такого же размера следующим образом: сначала должны идти все отрицательные элементы, а затем все остальные.

Формат входных данных
В первой строке входных данных лежит натуральное число n — количество элементов массива (2≤n≤500).

Во второй строке находятся n целых чисел, разделённых пробелами — элементы этого массива. Элементы массива по модулю не превосходят 1000.

Формат выходных данных
В единственной строке выведите все элементы нового массива.

входные данные
4
1 -3 3 7
выходные данные
-3 1 3 7

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Lera11111111100000
23.04.2021 14:17

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   int N;

   cin >> N;

   vector<int>negative;

   vector<int>positive;

   for (int i = 0; i < N; i++) {

       int A;

       cin >> A;

       if (A < 0)

           negative.push_back(A);

       else

           positive.push_back(A);

   }

       

   for (int i = 0; i < negative.size(); i++)

       cout<< negative[i]<<" ";

   for (int i = 0; i < positive.size(); i++)

       cout << positive[i] << " ";

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота