Ametov2007
14.02.2022 07:56

Задание 1. Напишите программу, определяющую принадлежность точки х отрезку [a;b]. (все переменные опишите как real и введите с клавиатуры).

Для проверки принадлежности точки х отрезку [a;b] воспользуйтесь условием (x>=a) and (x<=b)

Примеры ввода-вывода:

Задание 2. Вводится порядковый номер дня недели n.

При значениях n = 1, 2, 3, 4, 5 – вывести «Это рабочий день», при n = 6, 7 – вывести «Это выходной»,

во всех других случаях – вывести «Ошибка ввода».

(При определении условия n = 1, 2, 3, 4, 5 используйтесь условием (N= 1)or(N= 2)or(N= 3) и т.д..

Задание 3. Вводятся оценки (f, a, g, h ) за 4 контрольные работы – по физике, алгебре, геометрии и химии. Если каждая оценка больше или равна 4, вывести на экран «МОЛОДЕЦ!».

В остальных случаях вывести «ПОДТЯНИСЬ!». (Используйте сложное условие)

Задание 4. Проверить, существует ли треугольник со сторонами a, b, c (ввести с клавиатуры). Для проверки используйте неравенство треугольника: сумма длин любых двух сторон должна быть больше третьей. То есть нужно проверить одновременно три условия: a+b>c, a+c>b, b+c>a.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
polinapoluunaa
15.08.2020 04:44

«Alt+[Shift]+Tab» — переключение между окнами;
«Alt+F4» — закрыть активное окно;
«Alt+Space (пробел)» — открытие системного меню окна. С него можно закрывать, сворачивать, разворачивать, перемещать и изменять размер окна без мыши;
«Alt+Shift» или «Ctrl+Shift» — переключить язык;
«Ctrl+Alt+Delete» — открытие окна «Безопасность Windows»;
«Win» — открытие/закрытие меню «Пуск»;
«Ctrl+Esc» — открытие/закрытие меню «Пуск»;
«Win+D» — свернуть/восстановить все окна, включая диалоговые;
«Win+E» — открытие программы «Проводник»;
«Win+R» — открытие окна «Запуск программы» («Пуск» --> «Выполнить…»);
«Win+F» — открытие окна для поиска;
«Win+L» — заблокировать компьютер;
«Win+M» — сворачивает все окна, кроме диалоговых;
«Win+Pause/Break» — открытие окна «Система»;
«Ctrl+Shift+Esc» — открытие окна «Диспетчер задач»;
«Print Screen» — поместить снимок всего экрана в буфер обмена. В MS-DOS использовалась для вывода на принтер содержимого экрана;
«Alt+Print Screen» — поместить снимок активного окна в буфер обмена;

0,0(0 оценок)
Ответ:
Semev
03.03.2021 12:15

//На VS 2010 решается так, в других средах разработки может нужно к заголовкам добавить .h или убрать подключение пространства имен STD :(Console application)

 

#include <iostream>
#include <stdlib.h>
#include <time.h>
#include <conio.h>
using namespace std;

void Print(int m, int ** matr)  // Функция печати матрицы на экран
{
for(int i = 0; i< m; i++)
{
for(int j = 0; j<m; j++)
{
cout.width(4);
cout<<matr[i][j];
}
cout<<endl;
}
}

void search_and_print(int X, int **M) //Функция поиска элементов с их сортировкой и выводом на экран
{
int razmer = ((X*X) - X)/2;
int *mas = new int [razmer];
int Y = X - 1;
float srednee = 0;
int index = 0;
for (int j = 0; j<Y;j++)
{
for(int i = 0; i<(X-1);i++ )
{
mas[index] = M[i][j];
index++;
}
Y--;
}
for(int i = 0; i<(razmer-1); i++) //Сортировка методом выбора. X-1 раз ищем наименьший элемент.
{
//Принимаем за наименьший первый элемент из расматриваемых:
int min = i;
//Поиск минимального элемента из неупорядоченных:
for(int j = i+1;j<razmer;j++)
{
//Если нашли меньший элемент, запминаем его номер:
if(mas[j]<mas[min]) min = j;
}
//Обмен элементов:
int a = mas[i];
mas[i] = mas[min];
mas[min] = a;
}
cout<<"\nUporyado4enniy massiv:\n";
//Вывод и суммирование элементов отсортированного массива для среднего
for(int i = 0;i<razmer;i++)
{
cout<<mas[i]<<ends;
srednee += mas[i];
}
//Поиск арифметичесгоко реднего}
srednee = srednee/razmer;
cout<<"\nSrednee: "<<srednee;
delete [] mas;
}
void main()
{

srand ((unsigned)time(NULL));
int X;
cout<<"Vveditrazmer matritsi po gorizontaly i po vertikaly:\n";
cin>>X;
int** Matr;
Matr = new int* [X];   //Безопасный задания динамического

Matr[i] = new int[X]; // двумерного массива.
for(int j =0; j<X; j++)  //Заполняем матрицу
{    Matr[i][j] = rand()%10-5;} //Числами от -5 до 5
}
cout<<"Ishodnaya matritsa:\n";
Print(X,Matr);
search_and_print(X,Matr);
_getch();
delete [] Matr;
}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота