хорошист100000000000
15.11.2020 11:09

Написать программу вычисления значения функции F при любых целых a, b, c: F=3•a - корень из c+a | b²-81|​


Написать программу вычисления значения функции F при любых целых a, b, c: F=3•a - корень из c+a | b²

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
лидия87
22.03.2021 22:04
// PascalABC.NET 3.3, сборка 1562 от 02.11.2017
// Внимание! Если программа не работает, обновите версию!

procedure ЗаменаЦифры(Исходное,Заменяющее:int64; var Результат:string);
begin
  var ИсхСтрока:=Исходное.ToString;
  var ЗамСтрока:=Заменяющее.ToString;
  Результат:=ИсхСтрока.Replace(ИсхСтрока.ToCharArray.Max,ЗамСтрока)
end;

begin
  var КоличествоЧисел:=ReadInteger('Введите количество чисел для обработки:');
  var ОчередноеИсходное,ОчередноеЗаменяющее:int64;
  var РезультатЗамены:string;
  Loop КоличествоЧисел do begin
    Write('Введите исходное целое число: '); Read(Очередноеисходное);
    Write('Введите целое число для замены: '); Read(ОчередноеЗаменяющее);
    ЗаменаЦифры(ОчередноеИсходное,ОчередноеЗаменяющее,РезультатЗамены);
    Writeln('Результат замены: ',РезультатЗамены)
    end
end.

Пример
Введите количество чисел для обработки: 5
Введите исходное целое число: 15630
Введите целое число для замены: 8
Результат замены: 15830
Введите исходное целое число: 235235
Введите целое число для замены: 11
Результат замены: 23112311
Введите исходное целое число: 6
Введите целое число для замены: 352
Результат замены: 352
Введите исходное целое число: 999
Введите целое число для замены: 88
Результат замены: 888888
Введите исходное целое число: 12307347740
Введите целое число для замены: 131313
Результат замены: 12301313133413131313131340
0,0(0 оценок)
Ответ:
Tosya111
19.12.2021 13:04
// PascalABC.NET 3.3, сборка 1570 от 04.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(11,-29,150); a.Println;
  Writeln('Ср.арифм. положительных: ',a.Where(x->x>0).Average:0:3);
  Writeln('Ср.арифм. отрицательных: ',a.Where(x->x<0).Average:0:3);
  Swap(a[1],a[6]);
  Writeln('Результирующий массив'); a.Println
end.

Пример
91 109 113 119 17 95 41 131 -15 117 -14
Ср.арифм. положительных: 92.556
Ср.арифм. отрицательных: -14.500
Результирующий массив
91 41 113 119 17 95 109 131 -15 117 -14
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота