хани2005
12.05.2021 01:17

ЗА 1 ЗАДАНИЕ Написать программу, которая решает следующую задачу.
Проверить, принадлежит ли точка 3 и 4 координатной четверти.
Программу можно написать в любом редакторе Word или Блокнот

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Максим228prs
08.09.2021 12:28
Четное число делится на два, а кратное пяти делится на пять, поэтому число должно делиться без остатка на 2х5=10

// PascalABC.NET 3.0,сборка 1076
begin
  var n:=ReadInteger('Длина последовательности: ');
  var a:=ArrRandom(n,-50,50);
  Writeln('Исходная последовательность');
  a.Println;
  Writeln('Сумма элементов: ',a.Sum);
  Write('Кол-во четных, кратных пяти: ');
  Writeln(a.Where(x-> x mod 10 = 0).Count)
end.

Тестовое решение:
Длина последовательности: 20
Исходная последовательность
-4 21 -21 -23 14 -39 -12 1 -7 4 17 -45 30 -48 -19 -12 27 -46 -37 15
Сумма элементов: -184
Кол-во четных, кратных пяти: 1
0,0(0 оценок)
Ответ:
alextrasted
17.01.2023 21:54
Program zadacha3;
var V, Vo,a ,b, t, c, H: integer;
begin
  writeln('моя программа вычисляет скорость при равноускоренном движении');
  writeln('введите начальную скорость');
  readln(a);
  writeln('введите ускорение');
  readln(a);
  writeln('введите время');
  readln(t);
  writeln('введите шаг');
  readln(H);
  for b:=t to c do
    begin
      t:=t+H;
      V:=Vo+a*t;
    end;
  writeln('скорость равна V:= ',V);
end.

После эндом на закрытии цикла не стояло точки с запятой, и где у тебя написано в третей строчке снизу 7V, что это я так и не понял? Я убрал оттуда семёрку, если не так то поменяй, я в формулу не вдавался.
И у тебя ответ в цикле стоит я не знаю так должно быть или нет, обрати внимание на это, в своём варианте я переставил ответ на после цикла
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота