с программированием. Нужно написать программу по заданию, в которой будет ПОДПРОГРАММА и ОСНОВНАЯ ПРОГРАММА Я написала обычную программу, но не знаю как переделать ее под задание const N = 10; var a: array[1..N] of integer; i: integer; sr: real; sum: integer; begin randomize; for i:=1 to N do a[i]:=random(50)+1; sum := 0; for i:=1 to N do sum := sum + a[i]; sr:= sum/N; for i:=1 to N do write(a[i]:3); writeln; writeln('Среднее арифм.: ',sr:4:2); for i:=1 to N do if a[i]>sr then write(sr:4:2, ' ') else write(a[i], ' '); writeln; end.
Зная количество бит в двоичной записи числа, можно посчитать количество бит в восьмеричной записи, так как из двоичной в восьмеричную систему счисления число можно привести группировкой по трем соседним разрядам, начиная с младших. Например, есть число 1100111. Сгруппируем его разряды: (1)(100)(111)=147 - в восьмеричной СС. Пусть количество разрядов 2-ичного числа равно n. Тогда количество разрядов восьмеричного числа будет n/3, деленное нацело и округленное вверх. n=7 => n/3=7/3. Округляем, будет 3. a) 10111010. n=8 => 8/3 - 3 8-ричных разряда б) 1001111000111, n=13 => 13/3 - 5 8-ричных разрядов в) A18C. Сначала найдем n. Посмотрим, сколько значащих разрядов у старшей цифры. A=1010 - 4 разряда. У остальных цифр по 4 разряда всегда. Поэтому n=3*4+4=16 => 16/3 - 6 8-ричных разрядов. г) 1375BE. 1=1 : 1 разряд => n=5*4+1=21 => 21/3 - 7 8-ричных разрядов
m 8 5 n 3 ясно, что основание искомой с/с > 10. Проверим и удостоверимся, что в 11c|c действия выполняются верно. 11 c|c M=6 n = 4 ответ: основание системы 11, m=6, n=4
2. m m 65 n +2 n 4 4 m
5 5 4 2 4 очевидно, что основание искомой с/с > 6. Проверим по действиям в 7 с/с, при сложении в столбик, при m=3 и n=1 и удостоверимся, что всё верно. ответ: осн. с\с = 7, m=3, n=1