ilyapolitykin228
02.02.2021 23:10

сделать питон. – Калле, не забудь вечером полить клубнику! – Это мама выглянула из кухонной двери.

Калле успокаивающе помахал рукой. Да польет он клубнику! Только попозже. Когда убедится, что по городу не шныряют темные личности с преступными намерениями. К сожалению, маловероятно, чтобы такие типы появились, но лучше быть начеку!

Напишите программу, которая точно всегда начеку. Ваша программа должна из строки выбрать только те фразы, в которых есть только буквы и нет ничего другого.

Формат ввода
Вводится строка фраз, записанных через дефис, окруженный пробелами. Затем вводится строка-соединитель.

Формат вывода
Через строку-соединитель вывести только те фразы, в которых кроме букв нет ничего другого.

Пример 1
Ввод
Уж, - казалось бы, - куда - тише и - безмятежнее городок, - и - вдруг - бац! - выстрел среди - ночи
***
Вывод
куда***и***вдруг***ночи
Пример 2
Ввод
Да только 1 - они не - знают2 - Калле Блюмквиста!
!!
Вывод

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
artems242
28.12.2020 21:37
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (b1,q):=ReadReal2
      ('Введите значение первого члена и знаменателя прогрессии:');
  Writeln('Сумма первых 50 членов прогрессии равна ',
      b1*(1-q**50)/(1-q));
  Write('Члены прогрессии: '); SeqGen(50,i->b1*q**i).Println;
end.

Пример
Введите значение первого члена и знаменателя прогрессии: 1.2 2.3
Сумма первых 50 членов прогрессии равна 1.12623675002648E+18
Члены прогрессии: 1.2 2.76 6.348 14.6004 33.58092 77.236116 177.6430668 408.57905364 939.731823371999 2161.3831937556 4971.18134563788 11433.7170949671 26297.5493184244 60484.363432376 139114.035894465 319962.282557269 735913.249881719 1692600.47472795 3892981.09187429 8953856.51131087 20593869.976015 47365900.9448345 108941572.173119 250565615.998174 576300916.795801 1325492108.63034 3048631849.84979 7011853254.65451 16127262485.7054 37092703717.1224 85313218549.3814 196220402663.577 451306926126.227 1038005930090.32 2387413639207.74 5491051370177.81 12629418151409 29047661748240.6 66809622020953.4 153662130648193 353422900490843 812872671128940 1.86960714359656E+15 4.30009643027209E+15 9.8902217896258E+15 2.27475101161393E+16 5.23192732671205E+16 1.20334328514377E+17 2.76768955583067E+17 6.36568597841055E+17
0,0(0 оценок)
Ответ:
QwErtY314455667
12.03.2022 19:56
Uses GraphABC;var f:boolean;//переменная для выхода из программы procedure KeyDown(Key: integer);beginif Key=VK_Return then f:=false;//если нажата Enter-меняем значение флагаWindow.Caption:='Программа завершена';end;var   x,y:integer;       r:real;beginf:=true;//программа включена на работуsetwindowsize(600,600);//квадратное окноWindow.Caption:='Для окончания нажмите Enter';lockDrawing;r:=1;x:=windowwidth-round(50*r);y:=round(50*r);repeatwhile (y<windowheight-round(50*r))and f do begin  r:=r+0.002;  Window.Clear;  sleep(1);  DrawCircle(x,y,round(50*r));  MoveTo(round(x+50*r),y);  Arc(x,y,round(10*r),220,320);  Arc(x,y,round(30*r),220,320);  DrawCircle(x-round(20*r),y-round(14*r),round(10*r));  DrawCircle(x+round(20*r),y-round(14*r),round(10*r));  y:=y+1;  x:=x-1;  Redraw;  OnKeyDown := KeyDown;//если нажмем Enter, сменится флаг на false  end;                  // и программа завершится  x:=windowwidth-round(50*r);y:=windowheight-round(50*r);while (y>=round(50*r)) and f do begin  Window.Clear;  sleep(1);  r:=r-0.002;  DrawCircle(x,y,round(50*r));  MoveTo(round(x+50*r),y);  Arc(x,y,round(10*r),220,320);  Arc(x,y,round(30*r),220,320);  DrawCircle(x-round(20*r),y-round(14*r),round(10*r));  DrawCircle(x+round(20*r),y-round(14*r),round(10*r));  y:=y-1;  x:=x-1;  Redraw;  OnKeyDown := KeyDown;  end;x:=windowwidth-round(50*r);y:=round(50*r); until  not f; end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота