Adln48
26.01.2020 22:25

ЯЗЫК СИ. Написать программу на Си, которая из массива удаляет все повторные элементы. Например, массив 1 1 2 3 3 станет 1 2 3

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Gagarinaa
28.09.2020 12:07

#include <stdio.h>

#include <iostream>

#include <stdlib.h>

using namespace std;

 

 

#define kolichestvo 4

 

 

 

int main()

{

 int chislo, i, j;  

 char str [5];

 bool flag= false;

 

 cin>>chislo;

 itoa (chislo, str, 10);

 

 

 for (i= 0; i< kolichestvo- 1; i++)  

      for (j= i+ 1; j< kolichestvo; j++)  

           if (str[i]== str[j]) {  

            j= kolichestvo;

            i= kolichestvo- 1;

            flag = true;

           }

 

 printf ("%x\n", flag);

 getchar ();

 getchar ();

 return 0;

}

Объяснение:

0,0(0 оценок)
Ответ:
korsukova61oye48j
04.06.2022 09:25

Объяснение:

i=1

while(i<11):

if(i==1):

print(f"Факторіал {i} дорівнює 1 ")

elif(i==2):

print(f"Факторіал {i} дорівнює 2 ")

elif(i==3):

print(f"Факторіал {i} дорівнює 6 ")

elif(i==4):

print(f"Факторіал {i} дорівнює 24 ")

elif(i==5):

print(f"Факторіал {i} дорівнює 120 ")

elif(i==6):

print(f"Факторіал {i} дорівнює 720 ")

elif(i==7):

print(f"Факторіал {i} дорівнює 5040 ")

elif(i==8):

print(f"Факторіал {i} дорівнює 40360")

elif(i==9):

print(f"Факторіал {i} дорівнює 363240")

elif(i==10):

print(f"Факторіал {i} дорівнює 3632400 ")

i=i+1

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота