Arslanisyan
04.07.2022 04:58

Написать программу(Pascal),нахождение площадей параллелограмма и треугольника

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
angelikamaxowoz4v
27.02.2020 17:49

Непонятно, что за "надписи".

Предположим, что

1. "бабушка попросила"

2. "взяла лукошко"

3. "подошла к кусту"

4. "сорвала ягоду"

5. "сварили варенье"

тогда логика задачи будет следующей

 

бабушка попросила

Если Маша согласилась тогда

      взяла лукошко

      подошла к кусту

      Если куст с ягодами Тогда

          Пока (на кусте есть ягоды) и (лукошко пустое) Цикл

                  сорвала ягоду

          КонецЦикла

      КонецЕсли

      сварили варенье

КонецЕсли

 

В принципе, если несколько кустов, нужен цикл обхода по кустам пока не наполнится лукошко.

0,0(0 оценок)
Ответ:
Сова2211
17.03.2023 09:56

var i,s,p:integer; a:array [1..100] of integer;

begin 

s:=0; p:=0;

writeln('Vvedite masiv a:'); 

for i:=1 to 10 do begin

write('a[',i,']=');

readln(a[i]);

end;

for i:=1 to 10 do begin

if a[i]>0 then s:=s+a[i]; 

end;

s:=s*2;

writeln('Udvoennaya suma polozhitelnih elementov=',s);

writeln('Indexi elementov kotorie bolshe prediduschego:');

writeln;

for i:=2 to 10 do begin

if a[i]>a[i-1] then write(i,', ');

end;

for i:=2 to 10 do begin

if ((a[i]>=0) and (a[i-1]>=0)) or ((a[i]<0) and (a[i-1]<0)) then p:=p+1;

end;

writeln;

if p>0 then writeln('Masiv imeet pari sosednih elementov s odnakovimi znakami') else  writeln('Masiv ne imeet pari sosednih elementov s odnakovimi znakami'); 

readln(s);

end. 

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота