vlodimirfrolov
21.01.2021 20:46

Нужно написать программу цикла с параметром в паскале по задаче : Задана последовательность из n вещественных чисел. определить количество элементов последовательности, попадающих в заданный интервал (a,b)/

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
1Nicol1
19.05.2021 18:11

var

 x,a,b:real;

 i,n,count:integer;

begin

 count:=0;

 write('Интервал(a,b): '); readln(a,b);

 write('Кол-во чисел в посл.: '); readln(n);

 for i:=1 to n do

   begin

     readln(x);

     if (x>a) and (x<b) then

       inc(count);

   end;

 writeln('Кол-во в интерв.:',count);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота