caralina1
04.09.2022 05:18

Напишите программу на паскаль, которая считает сумму
цифр числа, введенного с клавиатуру. Если число
отрицательное, то программа берет модуль данного числа

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
alisgranger
17.05.2022 11:26
Решение, что называется, "в лоб" (далеко, очень далеко, не самое лучшее):
var s,k1,k5,k10,k50,k100,k500,k1000,k10000:integer;
begin
write('s = '); readln(s);
k1:=0; k5:=0; k10:=0; k50:=0; 
k100:=0; k500:=0; k1000:=0; k10000:=0;
while s>=10000 do begin s:=s-10000; k10000:=k10000+1; end;
while s>=1000 do begin s:=s-1000; k1000:=k1000+1; end;
while s>=500 do begin s:=s-500; k500:=k500+1; end;
while s>=100 do begin s:=s-100; k100:=k100+1; end;
while s>=50 do begin s:=s-50; k50:=k50+1; end;
while s>=10 do begin s:=s-10; k10:=k10+1; end;
while s>=5 do begin s:=s-5; k5:=k5+1; end;
while s>=1 do begin s:=s-1; k1:=k1+1; end;
writeln('k10000=',k10000,' k1000=',k1000,' k500=',k500,' k100=',k100,' k50=',k50,' k10=',k10,' k5=',k5,' k1=',k1);
writeln(' Всего купюр = ',k1+k5+k10+k50+k100+k500+k1000+k10000);
end.

Пример:
s = 27879
k10000=2 k1000=7 k500=1 k100=3 k50=1 k10=2 k5=1 k1=4
 Всего купюр = 21
0,0(0 оценок)
Ответ:
sts23
25.12.2021 03:55
#include <iostream>
using namespace std;
const int N = 8; //длина массива
int s = 0; //начальное значение суммы
int mas[N]; //объявляем статический массив длины N
int main()
{
    //вводим элементы массива
    for(int i = 0; i < N; ++i)
    {
        cin >> mas[i];
    }
    //пробегаемся по элементам массива
    for(int i = 0; i < N; ++i)
    {
        if(mas[i] > 0) //если элемент массива больше 0
            s += mas[i]; //прибавляем значение элемента к итоговой сумме
    }
    cout << s; //вывод суммы на экран
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота