алиярсик
16.05.2020 23:48

Составить программу в си: 1) составить программу, проверяющую, является ли заданное натуральное число совершенным, то есть равным сумме своих положительных делителей, кроме самого этого числа. 2) напечатать числа в виде следующей таблицы: 5 5 5 5 5 6 6 6 6 7 7 7 8 8 9

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Лена200115
01.10.2020 10:08
1)
#include <stdio.h>
#include <stdlib.h>

int sover (int n)
{
  int sum = 0;
  for (int i = 1; i<=n/2; i++)
    if (n%i==0) sum+=i;
  if (sum==n)
    return 1;
  else return 0;
}
int main()
{
  int n;
  printf ("N = ");
  scanf ("%d",&n);
  if (sover(n)==1)
    printf ("Sovershennoe");
  else printf ("Ne sovershennoe");
  printf("\n");
  system ("PAUSE");
  return 0;
}

2)
#include <stdio.h>
#include <stdlib.h>

int main()
{
  for (int i = 1; i<=5; i++)
  {
    for (int j = 1; j<=5-i+1; j++)
      printf ("%d ",5+i-1);
    printf ("\n");
  }
  system ("PAUSE");
  return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота