zjablja
29.05.2022 11:04

напишите программы на pythone, без функций. только через массивы на все вопросы)) которые есть Зачет по теме «Массивы (списки)»
Дан массив (список) А, состоящий из n натуральных чисел:
1) Введите значения элементов массива с клавиатуры в столбец.
2) Введите значения элементов массива с клавиатуры в строку через пробел.
3) Заполните массив по формуле, зависящей от индекса элемента массива. Например, а[i]=i2
4) Заполните массив случайными числами принадлежащими [-30; 30]
5) Выведите на экран значения элементов массива.
6) Найдите сумму положительных элементов массива.
7) Найдите количество отрицательных элементов массива.
8) Найдите в массиве элемент, равный значению X (X – вводится с клавиатуры), или сообщите, что его там нет.
9) Найдите минимальный элемент массива.
10) Найдите максимальный элемент массива и его порядковый номер.
11) Выполните реверс массива.
12) Выполните сдвиг элементов массива влево.
13) Выполните сдвиг элементов массива вправо.
14) Отберите все отрицательные, нечетные элементы массива А, в новый массив В.
15) Выполните сортировку массива по возрастанию.
16) Выполните сортировку массива по убыванию.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
2o2o
08.12.2021 17:20

Компьютерная графика - раздел информатики, который изучает средства и создания и обработки графических изображений при компьютерной техники. Несмотря на то, что для работы с компьютерной графикой существует множество классов программного обеспечения, различают четыре вида компьютерной графики. Это растровая графика, векторная графика, трёхмерная и фрактальная графика. Они отличаются принципами формирования изображения при отображении на экране монитора или при печати на бумаге.

Растровую графику применяют при разработке электронных (мультимедийных) и полиграфических изданий. Иллюстрации, выполненные средствами растровой графики, редко создают вручную с компьютерных программ. Чаще для этой цели используют отсканированные иллюстрации, подготовленные художником на бумаге, или фотографии. В последнее время для ввода растровых изображений в компьютер нашли широкое применение цифровые фото- и видеокамеры. Соответственно, большинство графических редакторов, предназначенных для работы с растровыми иллюстрациями, ориентированы не столько на создание изображений, сколько на их обработку. В Интернете применяют растровые иллюстрации в тех случаях, когда надо передать полную гамму оттенков цветного изображения 


0,0(0 оценок)
Ответ:
smirnovakrestin
28.09.2020 00:07
#include <iostream>
#include <stdlib.h>
using namespace std;

int main() {
const int n = 10;
int a[n];
int k=0;

srand(time(0));
for (int i = 0; i < n; i++) {
a[i]=-20 + (101.0 / RAND_MAX) * rand();
cout << a[i] << " ";
}
cout <<"\n";
cout << "Чётные числа:\n";

for (int i = 0; i < n; i++){
 if (a[i] % 2 == 0) {
  cout << a[i] << " ";
  k++;
 }
}
cout <<"\n";
if (k > n-k) cout << "Чётных больше"; 
else if (k < n-k) cout << "Нечётных больше"; 
else cout << "Чётных и нечётных поровну";
cout <<"\n";

return 0;
}

Пример:
27 11 77 59 28 8 59 64 16 80
Чётные числа:
28 8 64 16 80
Чётных и нечётных поровну
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота