Ира0386
13.03.2020 16:54

Напишите программу, которая позволяет вычислить остаток от деления на 1 00 000 007 значения функции Эйлера от некоторого биноминального коэффициента (выбрать k элементов из n). В качестве ответа на задание впишите одно число - ответ при n= 202120, k=2021

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Wector11211
02.12.2022 19:20
Система счисления значит, что число, являющееся основанием это 1 десяток. То есть в 8 с.с числа 8 нет => 7+1 = 10 в 8 с. с. Для чисел, символов которых нет, используются буквы латинского алфавита. A(10), B(11) и т. д...

Решение:

Постепенно делим на два и записываем остаток
135 1
67 1
33 1
16 0
8 0
4 0
2 0
1
Записываем снизу вверх и получаем 10000111 в двоичной системе счисления

То же самое для восьмеричной, но делим на 8:
135 7
16 0
2
Получаем 207 в восьмеричной с. с.

Теперь... да, в шестнадцатеричной.
135 7
8
Получилось 87.
0,0(0 оценок)
Ответ:
2katena
11.08.2020 06:12
1) program p1;
var a,b:integer;
begin
writeln('Введите 1-е число: ');read(a);
writeln('Введите 2-е число: ');read(b);
if(a>=b) then writeln('максимальное число: ', a) else  writeln('максимальное число: ', b);
end.

2)
program p1;
procedure MaxNumber(a,b: integer; var max: integer);
begin
   if a>=b then max:=a else max:=b;
end;
var a,b,c,d,m:integer;
begin
writeln('Введите 1-е число: ');read(a);
writeln('Введите 2-е число: ');read(b);
writeln('Введите 3-е число: ');read(c);
writeln('Введите 4-е число: ');read(d);
MaxNumber(a,b,m);
MaxNumber(m,c,m);
MaxNumber(m,d,m);
writeln('максимальное число: ',m);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота