Котан112
22.10.2020 19:29

Напишите программу (pascal)(геометрические построения средствами программирывания)


Напишите программу (pascal)(геометрические построения средствами программирывания)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
skrydyya
29.10.2021 16:27

static void Main(string[] args)

       {

           int N = 0;

           Console.Write("Введите размерность массива: ");

           N = Convert.ToInt32(Console.ReadLine());

           double[,] mas = new double[N, N];

           double sum = 0;

           int viborStroki = 0;

           Console.Write("Введите номер строки: ");

           viborStroki = Convert.ToInt32(Console.ReadLine());

           Random rnd = new Random();

           for(int i = 0; i < N; i++)

           {

               for(int j = 0; j<N; j++)

               {

                   mas[i, j] = rnd.Next(0, 10);

               }

           }

           for (int i = viborStroki - 1; i < viborStroki; i++)

           {

               for(int j = 0; j < N; j++)

               {

                   sum += Math.Pow(mas[i, j], 2);

               }

           }

           Console.WriteLine();

           Console.Write("Массив: ");

           Console.WriteLine();

           for (int i = 0; i < N; i++)

           {

               for (int j = 0; j < N; j++)

               {

                   Console.Write(String.Format("{0,3}", mas[i, j]));

               }

               Console.WriteLine();

           }

           Console.Write("Сумма квадратов элементов {0}-й строки = ", viborStroki);

           Console.Write("{0}", sum);

           Console.ReadKey();

       }

Объяснение:

Вводим размерность массива, вводим номер строки, программа считает сумму квадратов элементов введённой строки.

0,0(0 оценок)
Ответ:
Iriska91l23
26.08.2020 17:32
1. Современный вариант (коротко, быстро и наглядно, кто знает). Так уже начали учить в некоторых школах.

// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ArrRandom(ReadInteger('n='),1,300).Println.
      Where(k->(k>=100) and ((k mod 100) div 10=0));
  if s.Count>0 then Writeln(s.Max) else Writeln('Нет элементов')
end.

Пример
n= 15
76 283 171 140 113 65 185 35 202 42 93 51 205 76 138
205

2. А так по-прежнему учат в большинстве школ. Стиль "80-х годов века". Долго, длинно, можно наделать ошибок, но по-другому эти учителя сами не могут.

const
  nn=100;
var
  i,n,max:integer;
  a:array[1..nn] of integer;
begin
  Write('n=');
  Read(n);
  Randomize;
  max:=0;
  for i:=1 to n do begin
    a[i]:=Random(300)+1;
    Write(a[i],' ');
    if (a[i]>=100) and ((a[i] mod 100) div 10=0) then
      if a[i]>max then max:=a[i]
    end;
  Writeln;
  if max>0 then Writeln(max)
  else Writeln('Нет элементов')
end.

Пример
n=15
219 68 131 115 104 169 80 288 143 108 124 214 50 101 1
108
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота