speedoflight3
02.08.2022 14:39

Паскаль: дан список фамилий учащихся. определите количество букв в самой длинной фамилии, выведите эти фамилии в файл
​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
7547854
29.05.2023 04:39

#include <iostream>

#include <vector>

using namespace std;

int am_dig(int k){

   int res = 0;

   while(k > 0){

       res++;

       k /= 10;

   }

   return res;

}

double average(vector<double> a){

   double sum = 0;

   for(auto i: a)

       sum += i;

   return sum/a.size();

}

int main() {

   vector<double> a;

   double x = 1;

   while(x != 0){

       cin >> x;

       if(am_dig(x) == 3)

           a.push_back(x);

   }

   if(a.size() == 0)

       cout << "NO";

   else

       cout << average(a);

}

0,0(0 оценок)
Ответ:
Nastusha21032005
20.11.2020 17:21
Program ZAD00; {} uses crt;
var a,b:array[1..20] of real;
i:integer;
mina,minb,s:real;
Begin
{ заполнение массива А}
for i:=1 to 7 do begin write('введите элементы a[',i,']='); read(a[i]); end;
{ заполнение массива B}
for i:=1 to 9 do begin write('введите элементы b[',i,']='); read(b[i]); end;
{ min в массиве А}
mina:=a[1];
for i:=1 to 7 do begin
a[8]:= 32767 ;
if (a[i]>= a[i+1]) and (a[i+1]<=mina) then mina:=a[i+1]  end;
{ min в массиве B}
minb:=b[1];
for i:=1 to 9 do begin
b[10]:=32767;
if (b[i]>= b[i+1]) and (b[i+1]<=minb) then minb:=b[i+1]  end;
{ сложение minA и minB}
s:=mina+minb;
{ вывод результатов на экран
for i:=1 to 7 do begin write(a[i],' '); writeln; end;
for i:=1 to 9 do begin write(b[i],' '); writeln; end;
writeln('minA=',mina);
writeln('minB=',minb);
writeln('сумма их s=', s);
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота