Darvin2004
23.08.2022 09:11

Дан файл, содержащий размерность одномерного вещественного массива и его содержание. Написать программу, создающую и инициализирующую массив указанными данными. Содержимое массива вывести на экран. Содержимое файла заполнить самостоятельно.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
4kusssssp08s5c
07.04.2021 14:06
Const n=5;
var 
a:array[1..n,1..n] of integer;
b:array[1..n] of integer;
i,j,max,min,s:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to n do
  begin
   a[i,j]:=random(21);
   write(a[i,j]:4);
  end;
  writeln;
 end;
max:=a[1,n];
for i:=2 to n do
  if a[i,n-i+1]>max then max:=a[i,n-i+1];
writeln('1. max = ',max);
for i:=1 to n do
 begin
 min:=a[i,1];
 for j:=2 to n do
  if a[i,j]<min then min:=a[i,j];
 b[i]:=min;
 end;
s:=0;
writeln('2. Массив B');
for i:=1 to n do 
 begin
 write(b[i]:4);
 s:=s+b[i];
 end;
writeln;
writeln('3. среднее = ',s/n);
for i:=1 to n do 
 if b[i]>s/n then write(b[i]:4);
writeln;
end.

Пример:
Исходный массив:
  10  19  15  17  10
  12  12  10   1   5
  17   8   8  14  15
  12  11   8   0  13
   2   2   4  10   6
1. max = 11
2. Массив B
  10   1   8   0   2
3. среднее = 4.2
  10   8
0,0(0 оценок)
Ответ:
Дианчик777
11.06.2020 05:19
Лучше скачайте прикреплённый файл, так как здесь всё слилось))
1) varA, B: integer;beginreadln(A);readln(B);if (A>B) then writeln(A)else writeln(B);end.2)varA, B: integer;beginreadln(A);readln(B);if (A>B) then writeln(B)else writeln(A);end.3)varA, B: integer;beginreadln(A);readln(B);if (A>B) then  beginwriteln (A, ' - максимальное число');writeln (B, ' - минимальное число');end;if (B>A) then beginwriteln (B, ' - максимальное число');writeln (A, ' - минимальное число');end;end.4)varA, B, c, d: integer;beginreadln(A);readln(B);c:= A+2*B;d:= 3*A-B;if (c>d) then  writeln ('A+2B > 3A-B')else writeln ('3A-B > A+2B');end.
Воот))
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота