01061969
01.02.2023 16:48

На С++. Сформировать массив целых чисел размерностью N. Поменять местами пары соседних элементов в массиве: 0 и 1, 2 и 3, 4 и 5 и т.д.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ЦУКПРОЛ
28.03.2022 23:25

информационная безопасность

Объяснение:

XXI век называют веком информации. Доступ к информационным ресурсам получает каждый, кто имеет компьютер с выходом в интернет. И, безусловно, благодаря легкости получения информации, открываются новые возможности в области образования и работы в различных отраслях. Формируется новое качество жизни, новый уровень комфортности, и появляются новые проблемы…

Основная проблема использования сети кроется в самом главном ее преимуществе – интерактивности. Ведь каждый человек может, как получать, так и создавать информацию, размещая её для всеобщего использования. Экспертизе размещаемая информация не подлежит.

Таким образом, наряду с позитивными результатами, которые принесла эпоха информатизации, можно отметить и такое негативное явление, как манипулирование информацией (дезинформация, сокрытие или искажение информации), что рассматривается как угроза информационной безопасности личности.

Поток разнообразной информации порой несёт угрозу в виде отрицательного воздействия на психику. Изолировать школьника от негативной, опасной и лживой информации невозможно. Многие ребята пользуются мобильными устройствами для выхода в сеть, что открывает им доступ к информации разного качества в любое время.

Поэтому каждому человеку необходимо научиться критическому восприятию информации, формируя тем самым систему своей внутренней защиты. Необходимо научиться:

оценивать значимость и необходимость получения той или иной информации;

определять уровень потенциальной опасности различных источников информации;

осуществлять отбор информационных потоков;

адекватно реагировать на разнообразную информацию.

Для оценки надежности информации учеными (JamesM. Shiveley, PhilipJ. Vanfossen) разработаны критерии и ряд вопросов к ним. Предлагаем, используя эти критерии (протокол исследования), оценить надежность тех информационных источников, которыми Вы привыкли пользоваться. P.S. мало за такой вопрос

0,0(0 оценок)
Ответ:
Емсимася
14.02.2023 17:33
На вывод работало с 866, а на ввод с 1251 (SetConsoleCP();).
В массив пишет каракули.
Функции  setlocale(LC_CTYPE, "Russian"); setlocale(LC_ALL, "Russian"); тоже не Отлично работают с ОТОБРАЖЕНИЕМ текста в консоли, но с чтение из ее это ужас. 
В С++ всегда с этим проблема была, с обработкой вводимой кириллицы  с консоли.
Это те еще танцы с бубнами. Учитывая еще то, что многие функции писались исключительно под XP а про поддержку в версиях выше речи не было вообще.
Есть выходы конечно, но у меня не получилось отобразить кириллицу, считать с консоли, и вывести обратно. Что-то одно всегда не работало.Либо выводило правильно, а записывало каракули, либо каракули выводит а записывает правильно. 
Если убрать все заморочки с кодировками, то вот код:

int _tmain(int argc, _TCHAR* argv[])
{
setlocale(LC_CTYPE, "Russian");
char *str=new char[]; 
cout<<"Введите слово: "; cin>>str;

   for (int i = 0; i < strlen(str); i++)
    {
       if(str[i]!='я'&&i%2!=0){cout<<str[i];} 
    }

system("PAUSE");

}
Вычеркните из слова все буквы я, стоящие на четных местах. написать программу на с++
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота