bts23
17.04.2023 22:24

СТО ОТДАМ ЗА РЕШЕНИЕ ЗАДАНИЯ Написать программу, которая проверяет правильность ввода пароля, Пользователь может ввести пароль Лишь 3 раза, а затем получит сообщение об ошибке, если введенный пароль неверный или приветствие, если пароль верный.​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
bugaamn1
20.06.2020 11:05
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

type
  CheckBalls=class
 
  private
   
    ad:array of real; // диаметры шариков
    ap:array of real; // веса шариков
    etD:=24.0; // эталонный диаметр
    derD:=2.0; // эталонное предельное отклонение
    etP:=74.0; // эталонный вес
    derP:=3.0; // эталонное предельное отклонение
   
    procedure CheckBall(m:integer);
    // проверка шарика с указанным номером
    begin
      Write('Шарик № ',m,': диаметр - ');
      if Abs(aD[m-1]-etD)<=derD then Write('норма')
      else Write('брак');
      Write(', вес - ');
      if Abs(aP[m-1]-etP)<=derP then Writeln('норма')
      else Writeln('брак')
    end;
  
 
  public
 
    constructor(ma,mp:array of real);
    begin
      ad:=Copy(ma);
      ap:=Copy(mp);
    end;
   
    procedure CheckAllBalls;
    begin
      for var i:=1 to ad.Length do CheckBall(i)
    end;
 
end;

begin
  var n:=120; // число шариков
  var a:=SeqRandom(n,200,280).Select(t->t/10).ToArray;
  var b:=SeqRandom(n,700,800).Select(t->t/10).ToArray;
  Writeln('Параметры шариков (диаметр,вес):');
  a.Zip(b,(p,q)->(p,q)).Println;
  Writeln('Результаты контроля:');
  var oL:=new CheckBalls(a,b);
  oL.CheckAllBalls
end.
0,0(0 оценок)
Ответ:
yaritos
29.03.2020 00:51
1. Для цикла For есть решение выложенное выше  от Srzontmp.

2. Почти ничего не меня получим код для цикла while:
var
  i, n, k: integer;
begin
  i := 2;
  readln(n);
  while i <= n div 2 do begin
    if (n mod i) = 0 then k := i;
    i:=i+1;
    end;
  writeln('наибольший делитель ', n, ' = ', k);
end.

3. Аналогично для цикла Repeat:
var
  i, n, k: integer;
begin
  i := 2;
  readln(n);
  repeat
    if (n mod i) = 0 then k := i;
    i:=i+1;
  until i> n div 2;
  writeln('наибольший делитель ', n, ' = ', k);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота