FD140
03.02.2023 08:39

1.Найти сумму элементов массива. Размерность массива и элементы вводятся с клавиатуры. Вывести на экран все элементы 2.Написать программу, которая выводит на экран массив, элементы которого заданы случайным образом на интервале [-17;24]. Найти сумму элементов, состоящих на нечётных местах.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
prozorovamary23
08.04.2020 10:03
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

1. Если надо преобразовать число без знака в число

begin
  var n:=ReadInteger; // исходное число
  n:=n.ToString.Inverse.ToInteger; // полученное число
  n.Println; // вывод результата
end.

2. Если нужно только вывести результат

begin
  var n:=ReadInteger; // исходное число
  n.ToString.Inverse.ToInteger.Println
end.

3. Если надо только поменять местами символы, введенные с клавиатуры (например, два символа, изображающие число)

begin
  ReadlnString.Inverse.Println
end.

4. Если заданное число может быть отрицательным

begin
  var n:=ReadInteger; // исходное число
  var s:=Sign(n); // знак числа
  n:=Abs(n); // модуль числа
  n:=n.ToString.Inverse.ToInteger*s; // полученное число
  n.Println; // вывод результата
end.
0,0(0 оценок)
Ответ:
ПолЕчка11117
08.04.2020 10:03

{ Треугольник задан координатами вершин (x1;y1),(x2;y2),(x3;y3).

Найти площадь треугольника (используя формулу Герона) }

uses crt;

var x1,x2,x3,y1,y2,y3,a,b,c,s,p : real;

begin

clrscr;

write('x1=');readln(x1);

write('y1=');readln(y1);

write('x2=');readln(x2);

write('y2=');readln(y2);

write('x3=');readln(x3);

write('y3=');readln(y3);

a:=sqrt(sqr(x1-x2)+sqr(y1-y2));

b:=sqrt(sqr(x2-x3)+sqr(y2-y3));

c:=sqrt(sqr(x3-x1)+sqr(y1-y3));

p:=(a+b+c)/2;

s:=sqrt(p*(p-a)*(p-b)*(p-c));

write('s=',s);

readln;

end.

формула герона!

А так я думаю эти задачки очень даже не сложные, только формулы надо знать!! !

периметр- это сумма всех сторон

например

begin

writteln( 'введите 3 стороны' ) ;

readln(a,b,c);

writeln(' периметр = ',a+b+c);

readln;

end.

Вот и все!! !

Удачи!

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота