vinks2905
11.07.2020 07:33

ответ нужен на паскале 1. Ввести массив из N целых чисел. Найти наибольшее число из элементов с четными номерами и сумму этих элементов. Вывести на экран наибольшее значение и сумму.
2. Ввести массив из N целых чисел. Удалить из него элементы с четными значениями. Найти сумму оставшихся значений. Полученный новый массив и сумму вывести на экран.
3. Ввести массив из N вещественных чисел. Удалить из него все элементы, расположенные перед минимальным элементом. Полученный новый массив вывести на экран.
4. Ввести массив из N символов. Вставить в него три символа после первого из пробелов. Полученный новый массив вывести на экран.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nicorobincom
22.01.2021 15:38
// Напишите программу, которая в последовательности натуральных чисел определяет количество
//чисел, кратных 3. Программа получает на вход количество чисел в
//последовательности, а затем сами числа. В последовательности всегда имеется число,
//кратное 3. Количество чисел не превышает 100. Введённые числа не превышают 300.
//Программа должна вывести одно число - количество чисел, кратных 3.

Var  i,j,x  :word;
     n      :integer;
begin
  writeln('Введите количество цифр в последовательности');
  Readln (j);
  if j>100 then //Проверка накличество чисел в последовательности
      begin
        writeln ('По условия задачи цифр не должно быть более 100');
        writeln ('Введите количесво цифр еще раз');
        readln (j);
      end;
  for i:=1 to j do
  begin
    Writeln ('Введите ',i,' число');
    readln (n);
    if n>300 then //проверка максимального значения числа
      begin
        writeln ('Данное число не удовлетворяет условиям задачи (>300');
        writeln ('Введите его еще раз');
        readln (n);
      end;
      n:= n mod 3;
      if n=0 then x:=x+1;
      end;
   Writeln ('Количество чисел, кратных 3:');
   Writeln (x);
end.
0,0(0 оценок)
Ответ:
indyouk014
22.01.2021 15:38
#include <iostream>
using namespace std;
int main()
{
     size_t N = 0, val = 0, count = 0;
     cin >> N;
     if (N < 100) {
         for(size_t i = 0; i < N; ++i) {
             cin >> val;
             if (val < 300) {
                 if (!(val % 3)) ++count;
             } else {
                 cout << "Value must be < 300" << endl;
                 exit(1);
             }
         }
     } else {
         cout << "N must be < 100" << endl;
     }
     cout << "Count: " << count << endl;
     return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота