kety0milka
17.09.2020 02:55

ответ нужен на паскале. 1. Написать программу, заносящую в файл нечетные числа от 3 до 17, а потом считывающую эти числа в обратном порядке с выводом их на экран.
2. Написать программу, заносящую в файл 10 натуральных чисел, введенных с клавиатуры. Создать новый файл, содержащий все локальные минимумы из исходного файла (локальным минимумом называется элемент, который меньше своих соседей). Считать новый файл и вывести все значения на экран.
«Блокнота» создать текстовый файл. Продублировать в нем все пустые строки. Вывести содержимое файла на экран построчно.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
маришка213
28.12.2021 23:53

главное меню  расположено в верхней строке окна заключает в себе все возможности программы, рассортированные по более или менее однотипным . для входа в меню необходимо либо воспользоваться мышью, либо нажать f10, затем перемещаться по меню с клавиш курсором. покинуть меню можно, нажав клавишу esc.

панели  – две равноправные таблицы, занимающие основную часть окна. внутри панелей может отображаться различная информация. одна из панелей является активной (на ней находится курсор и заголовок панели подсвечен), другая панель – пассивная. смена активное панели достигается нажатием tab или щелчком мыши в любой части панели. при этом курсор перемещается с одной панели на другуюкомандная строкаменю функциональных клавиш  запуск команд ms-dos из командной строкипросмотр содержимого файларедактирование файла встроенным редактором.копирование файла или каталогапереименование и перенос файла или каталога.создание нового каталогаудаление файлов и каталоговработа с группами файлов и каталогов

0,0(0 оценок)
Ответ:
bogdanb13
07.01.2021 00:35
Программа на python 3, перебирающая все возможные последовательности определённой длины:
def shortest_chains(n):
  def next_chains(chain):
    new_elems = set()
    for i in range(len(chain)):
      for j in range(i, len(chain)):
        new_elem = chain[i] + chain[j]
        if new_elem > chain[-1] and new_elem not in new_elems:
          new_elems.add(new_elem)
          yield chain + [new_elem]
  
  current_stage = None
  next_stage = [[1]]
  answer = []
  while len(answer) == 0:
    current_stage = next_stage
    next_stage = []
    for chain in current_stage:
      next_stage.extend(next_chains(chain))
    answer = [chain[1:] for chain in next_stage if chain[-1] == n]
  return answer
    
def print_solution(n):
  answer = shortest_chains(n)
  print("Для {} есть {} решений(-я, -е):".format(n, len(answer)))
  for i in range(len(answer)):
    print("{}. {}".format(i + 1, " ".join(map(str, answer[i]
  print()

Запустив, можно получить все 5 возможных решений для числа 7, по 4 решения для 15 и 23 и 87 решений для 63.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота