twopizzanumberone
18.05.2021 17:03

Напишите программу на языке С++ для решения следующей задачи: "Даны 2 числа - значение длины в сантиметрах и метрах. Равны ли они

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nikinouston342
14.01.2020 01:48

Короче, с выводом не очень понял, поэтому будет 4 варианта, выбери сам

Обязательная часть программы:

import datetime

year, month, day = int(input('Введите год: ')), int(input('Введите месяц: ')), int(input('Введите день: '))

date = datetime.date(year, month, day)

delta = datetime.timedelta(days=1)

date = str(date + delta).split('-')[::-1]

Тут нужно выбрать одну из строк, будем рассматривать на примере 31 декабря 2019 года(то, что стоит после решетки и саму решетку не копируй:

Вариант 1:

print(*date)     # 01 01 2020  --- это вывод(обычный)

Вариант 2:

print(int(date[0]), int(date[1]), date[2])    # 1 1 2020 (без ведущих нулей)

Вариант 3:

print(str(int(date[0])) + str(int(date[1])), date[2]) #11 2020(без нулей и пробелов)

Вариант 4:

print(str(date[0]) + str(date[1]), date[2])      # 0101 2020(без пробелов)

0,0(0 оценок)
Ответ:
anastasia1292
06.08.2021 21:19
Var A,R:integer;
Begin
WriteLn('Выберите тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, 0 - выход.');
ReadLn(R);
While R<>0 do
   Begin
   Write('Введите значение этой единицы времени: ');
   ReadLn(A);
   Case R of
   1:WriteLn(A,' сек = ',(A/60):0:3,' мин = ',(A/3600):0:3,' ч = ',(A/86400):0:3,' сут');
   2:WriteLn(A,' мин = ',(A/60):0:3,' ч = ',(A/1440):0:3,' сут = ',A*60,' сек');
   3:WriteLn(A,' ч = ',(A/24):0:3,' сут = ',A*3600,' сек = ',A*60,' мин');
   4:WriteLn(A,' сут = ',A*24,' ч = ',A*1440,' мин = ',A*86400,' сек');
   End;
   WriteLn;
   WriteLn('Выберите тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, 0 - выход.');
   ReadLn(R);
   End;
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота