arizonacoins
05.08.2022 16:59

Задача 2. Составить программу, решающую следующую задачу: Дано число а. Не пользуясь никакими другими операциями ,кроме умножения получить : а в 20 степени за 5 операций

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
skalapendra1212
02.03.2023 07:27
// PascalABC.NET 3.0, сборка 1156 от 30.01.2016
function Avg(a:array[,] of integer):real;
begin
  var s:=0; var k:=0;
  foreach var e:integer in a do
    if e>0 then begin s+=e; Inc(k) end;
  if k>0 then Result:=s/k else Result:=1e-100;
end;

begin
  var A:=MatrixRandom(4,4,-50,50); Writeln(A);
  Writeln('Среднее арифметическое положительных равно ',Avg(A):0:3);
  var B:=MatrixRandom(5,5,-30,30); Writeln(B);
  Writeln('Среднее арифметическое положительных равно ',Avg(B):0:3);
  var C:=MatrixRandom(4,5,-25,38); Writeln(C);
  Writeln('Среднее арифметическое положительных равно ',Avg(C):0:3);
end.

Тестовое решение:
[[35,35,5,-47],[14,34,35,-13],[25,-5,35,-29],[-7,10,-12,12]]
Среднее арифметическое положительных равно 24.000
[[-12,-17,-10,19,14],[20,17,-27,-2,16],[-3,-21,30,2,10],[5,-3,-17,-3,18],[0,-26,29,1,-22]]
Среднее арифметическое положительных равно 15.083
[[-5,-11,17,-4,15],[15,17,-24,36,15],[-8,-3,-22,28,-25],[-21,6,12,31,-1]]
Среднее арифметическое положительных равно 19.200
0,0(0 оценок)
Ответ:
baba22
03.12.2021 02:17

биология-

человек теплокровное животное - истинное

обезьяна насекомое - ложное

география -

франция находиться в Европе - истинное

великобритания больше США - ложное

информатика -

жёсткий диск служит для хранения информации - истинное

ОЗУ обрабатывает информацию - ложное

история -

вторая мировая война началась 1 сентября 1939 года - истинное

Гитлер был сыном Наполеона - ложное

математика -

2+3=5 - истинное

3+3=15 - ложное

литература -

войну и мир написал Толстой - истинное

Лермонтов написал "Евгений Онегин" - ложное

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота