irina567890
14.09.2020 06:34

решить задачу на ПИТОНЕ! Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 2. Кол. Чисел не превышает 1000. Программа должна вывести одно число - максимальное число, оканчивающееся на 2

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
mila336
15.06.2021 16:38

import random

mass = []

masscomp = []

max = 0

for i in range(0, 1000):

   mass.append(random.randint(0, 1000000))

   masscomp = [int(x) for x in str(mass[i])]

   if (mass[i] > max and masscomp[len(masscomp) - 1] == 2):

       max = mass[i]

print(max)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота