mrmrheik
01.08.2020 07:42

Написать программу, выводящую на экран информацию по заданному образцу: № 1.123456789100000009100000009100000009100000009123456789​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
царапина123
22.01.2021 21:13
Const nx=30;var i,j,p,n:integer;A:array[1..nx,1..nx] of integer;d,Sn,min:real;begin p:=1;write('Введите размер матрицы');Read(n);for i:=1 to n do beginfor j:=1 to n do beginA[i,j]:=random(3)-2;write(A[i,j]:4);end;writeln;end;writeln;writeln;for i:=1 to n do beginfor j:=1 to n do beginif i = j then begin if A[i,j]<> 0 then p:=p* A[i,j];write(A[i,j]:4);endelse write(' ':4);end;writeln;end;write('p =',p);writeln;writeln;for i:=1 to n do beginfor j:=1 to n do beginif (i= n -j +1) then begin if A[i,j]<> 0 then p:=p* A[i,j];write(A[i,j]:4);endelse write(' ':4);end;writeln;end;write('p =',p);end.
0,0(0 оценок)
Ответ:
ivan240620058p0bydq
03.06.2021 02:33

В данной программе предполагается что массив целочисленный 

Program Massiv;

Uses Crt;

var a:array[1..10] of integer;

       temp,max,i:integer;

begin

    clrscr; 

 

    for i:=1 to 10 do

          begin

              write('Введите  ',i, 'элемент массива: ' );

              readln(a[i]); 

         end;

   writeln;

 

     

 

 write('Исходный массив: ');

max:=a[1]; 

 

 for i:=1 to 10 do

     begin

         write(a[i])

          write('  ');

        if (a[i]>max) tnen max:=a[i];    

     end; 

 

 temp:=a[6];

 a[6]:=a[9];

a[9]:=temp;

 

 

 

 writeln;

  write('Массив после обмена: '); 

for i:=1 to 10 do

     begin

         write(a[i])

          write('  ');  

     end;

writeln;  

writeln('Максимальный элемент массива: ',max);

      readkey;

 

 end.

 

 

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота