Составить программу на паскале, работающую в двух режимах: в первом режиме производится нахождение максимального из A, B, C и D, во втором - функции y, заданной с графика. Выбор режима осуществить оператором CASE. Переменные A, B, C, D - целого типа. График во вложении
Граф - множество вершин и ребер, соединяющих эти вершины. Он несет информацию об элементах системы и связи между ними. Элементы системы изображаются как вершины или узлы графа. Отношения между ними изображаются как ребра или дуги графа. Деревом называют ациклический (то есть между любыми вершинами есть только один путь), связный (то есть от любой вершины графа можно добраться в другую) граф. Корень дерева - это вершина с нулевой степенью захода (то есть в нее не ведут другие ребра). Для неориентированного графа это просто выбранная нами вершина. Ветви - это ребра дерева. Листья дерева - это вершины с нулевой степенью исхода (то есть из них не выходят ребра), т.е. не имеющих поддеревьев. Надеюсь объяснил доступно.
var a: array[1..MAX_SIZE] of integer; i, size: integer;
procedure delete_odd_elements(); var i, j: integer; begin i := 1; repeat if odd(a[i]) then begin dec(size); for j := i to size do a[j] := a[j + 1] end else inc(i); until i > size; end;
begin writeln('Исходный массив: '); size := MAX_SIZE; for i := 1 to size do begin a[i] := random(100); write(a[i] : 3); end; delete_odd_elements; writeln; writeln('Полученный массив: '); for i := 1 to size do write(a[i] : 3); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку