cheri228
30.03.2023 17:37

Составить программу нахождения для заданного натурального числа всех делителей, кратных числу .формат входных данных входной файл содержит числа , формат выходных данных выведите искомые делители. примеры: вход6 3 выход3 6

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
verenikinaulia
21.06.2020 20:22
#include <iostream>
using namespace std;
int main()
{
    int a,b;
    cin >> a >> b;
    for (int i = 1; i <= a; i++)
    {
        if (a%i == 0)
        {
            if (i%b == 0)
            {
                cout << i << ' ';
            }
        }
    }
    system("pause");
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота