Атмир089997
16.07.2021 15:23

2 кода нужн 1. С клавиатуры вводятся 10 слов. Напишите программу, которая:
Напечатает слово, ближайшее к началу алфавита в списке (считаем, что все слова различны; выполнять аналогично поиску минимального из ряда чисел)
2. Создать проект заполнения массива А(9,9) 0 и 1 в шахматном порядке. Вывести
массив на форму в виде таблицы.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Даниил223223
22.04.2020 09:28
Const 
  N = 15;

var
  mas:array[1..15] of integer;
  i, max1, max2, min, c, d:integer;

begin
  c:=-1;
  max1:=-maxint;
  min:=maxint;
  max2:=-maxint;
  randomize;
  for i:=1 to N do
    mas[i]:=random(101)-50;
  write('Массив: ');
  for i:=1 to N do
    write(mas[i], ' ');
  writeln;
  for i:=1 to N do
  begin
    if (mas[i]>0) AND (mas[i]>max1) then
      max1:=mas[i];
   if (mas[i] mod 2 <> 0) AND (max2<mas[i]) then
   begin
     c:=i;
     max2:=mas[i];
   end;
   if (mas[i] mod 2 <> 0) AND (min>mas[i]) then
   begin
     d:=i;
     min:=mas[i];
   end;
  end;
  writeln('Максимальный положительный элемент: ',max1);
  writeln('Минимальный нечетный элемент: ',min);
  writeln('Максимальный нечетный элемент: ',max2);
  if c<d then
    writeln('Максимальный элемент стоит раньше')
  else
   writeln('Минимальный элемент стоит раньше');
end.
0,0(0 оценок)
Ответ:
DIANA89320
06.03.2023 05:54
1)
const
n=10;
var
a:array[1..n]of integer;
i,k:integer;
begin
        for i:=1 to n do
             begin
                 readln(a[i]);;;
                     if a[i]mod 5=0 then
                          k:=k+1;
             end;
writeln;
writeln(k);
end.

2)
const
n=10;
var
a:array[1..n]of integer;
i,S:integer;
begin
        for i:=1 to n do
             begin
                 a[i]:=random(21)-10;
                  write(a[i]:4);
                     if (abs(a[i]mod 10)=3) then
                          S:=S+a[i];
             end;
writeln;
writeln(S);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота