VladimirLapskiy
20.07.2022 01:02

вас мочь с заданиемна: Написать программу на Паскаль турбо
В двумерном массиве А[5, 8] найти минимальный элемент каждой из строк
и минимальный элемент каждого из столбцов. Для поиска минимального использовать подпрограмму, которая находит минимальной элемент в одной
строке, а для поиска максимального - функцию которая находит максимальный
элемент в одном столбце.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
tuysdik
17.12.2021 03:36
Если дальше завершить программу, то получим это:
program HelloWorld;
    function ez(a: longint): boolean;        var c: integer;        begin            ez := a >= 2;            for c := 2 to trunc(sqrt(a)) do if a mod c = 0 then ez := false        end;        var i, k: integer;        num: array [1 .. 100] of integer;
begin    for i := 0 to 99 do num[i+1] := i + 1;        k := 0;    i := 1;        while k < 7 do begin        if ez(num[i]) = true            then k := k + 1;        i := i + 2;    end;        write(num[i-2]);    end.
ответ 19
0,0(0 оценок)
Ответ:
MegaCrisp1
13.03.2023 00:34

2

Объяснение:

Мы видим что логическое выражение представляет из себя дизъюнкцию двух других логических выражений:

(x>10) и (x<15)x делится на 2

Для того чтобы всё логическое выражение было истинно, нужно чтобы хотя бы одно из выше указанных выражений было равно 1.

Первое выражение легко переписать в виде неравенства 10<x<15, что означает что искомый x находится между 10 и 15 не включительно. Самый минимальный целый положительный x подходящий под это условие это x=11.

Однако, если рассмотреть второе выражение, увидим, что мы можем также взять x кратный 2. Минимальный целый положительный x кратный 2 это и есть 2.

2 < 11, поэтому минимальным целым положительным x, чтобы выражение было истинно, является x=2. Мы имеем право его выбрать как ответ, ведь два условия дизъюнкции не требуют совместного выполнения.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота