Otahalepi
22.01.2021 00:15

Найти количество отрицательных элементов в каждой строке массива MxN, заполненного случайными числами от -25 до 25 Входные данные:
Количество строк: 4
Количество столбов: 5
Паскаль.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
MishaSim2003011
02.07.2021 10:09

Free Pascal

var

 a : array of array of integer;

 b : array of integer;

 s, i, j, n, m : integer;

begin

 writeln('Введите кол-во строк:');

 readln(m);

 writeln('Введите кол-во столбцов:');

 readln(n);

 randomize;

 setlength(a, n);

 setlength(b, m);

 for i:=0 to n-1 do

   setlength(a[i], m);

 for j:=0 to m-1 do begin

   s:=0;

   for i:=0 to n-1 do begin

     a[i,j] := random(50) - 25;

     if a[i,j] <0 then inc(s);

     write(a[i, j], '  ');

   end;

   b[j]:=s;

   writeln();

 end;

 writeln('--------------------------');

 for j:=0 to m-1 do

   writeln(j+1,' строка = ', b[j]);

end.


Найти количество отрицательных элементов в каждой строке массива MxN, заполненного случайными числам
0,0(0 оценок)
Ответ:
yfryjkngttyufddvn
02.07.2021 10:09

##

var n := ReadInteger;

var a := ArrRandom(n, -28, 27);

a.Println.Where(t -> t.Divs(3)).Product.Print


Найти количество отрицательных элементов в каждой строке массива MxN, заполненного случайными числам
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота