anonim869
16.06.2022 07:45

Напишите программу, которая будет 5 раз генерировать два случайных числа от 1 до 10 и сохранять их в переменные x и y. После этого, программа будет спрашивать у пользователя сумму двух переменных x и y.

Если пользователь отвечает правильно, то программа начисляет ему Иначе она будет просто выводить правильный ответ.

Не забудь вывести итоговый счет, ведь всем интересно насколько хорошо они отвечали

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
gagag590
02.07.2021 18:38

import random

score = 0

for i in range(5):

   x = random.randint(1, 10)

   y = random.randint(1, 10)

   print("Введите сумму")

   inp = int(input())

   if x + y == inp:

       print("Верно!")

       score += 1

   else:

       print("Правильный ответ -", x + y)

print("Итоговый счёт:", score)

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота