pczheka1
16.02.2023 17:20

с Python! Напишите программу, на вход которой непрерывно (в цикле) подаются введены пользователем данные. При введении каких-либо данных, кроме целых чисел, выводится сообщение об ошибке с генерирования исключения ValueError. Как только ввели целое число, выводится сообщение True и происходит выход из программы.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
мухтар112
07.07.2021 13:25

прикрепляю файл с рабочим кодом. При желании можно в  блоке except в строке print ввести любое выражение, которое должно появляться при некорректном значении.

while True:

   x=input()

   try:

       x=int(x)

       print('True')

       break

   except ValueError:

       print('ValueError')

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота