Лаура81и
05.10.2020 04:42

с !! Напишите программу, которая открывает указанный текстовый файл, а затем отображает список всех уникальных слов, найденных в файле.

Например ввод:
input.txt

Вывод:
Список уникальных слов из файла input.txt

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ritaazarenko5
19.03.2022 21:21
1) 1,5 Кбайта=1,5 * 1024 байта = 1,5 * 1024 *8 бит = 12288 бит
12288/3072 = 4 бита - на один символЗначит N=2^4 = 16 символов в алфавите.

2) 1 символ = 8 бит = 1 байт

150*40*60=360000 (символов/байт) 
это ответ и есть, но можно для удобства перевести в килобайты
1 килобайт = 1024 байт

360000/1024=351,5625

ответ: 360000 байт или 351,5625 килобайт

3) посмотрим сколько же всего символом на двух страницах:256*2 = 512 сиволов.Теперь посмотрим сколько байт они занимают:1 килобайт (по старым нормам) = 1024 байта (по новым уже нет :( )1024/16 = 64 байта. в одном байте 8 бит, значит 64 байта это 64*8 = 512 бит информации.разделим: 512/512 = 1 бит информации на символ. Мощность алфавита = 2 в степени количества информации на символ, то есть 2 в первой, или просто 2.ответ: мощность алфавита равна двум.
0,0(0 оценок)
Ответ:
flowersemenova2
19.03.2022 21:21
#include <iostream>
#include <math.h>

using namespace std;

int main()
{
    float a,b,c;
        int d;
        float x1, x2;

        cout << "ax^2+bx+c=0" << endl;
        cout << "Input a:" << endl;
        cin >> a;
        cout << "Input b:" << endl;
        cin >> b;
        cout << "Input c:" << endl;
        cin >> c;
        d= sqrt(b*b-4*a*c);
        x1=((-1)*b+d)/(2*a);
        x2=((-1)*b-d)/(2*a);
        cout << "x1=" << x1 << endl;
        cout << "x2=" << x2 << endl;
    return 0;
}

Но есть корень из дискриминанта нормально не получится - оно не напишет тебе + √13 допустим, он посчитает корни приблизительно.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота