MrCaT2005
05.01.2022 05:14

С++ Напишите программу, которая играет в игру "Угадай число" следующим образом: ваша
программа "планирует" число (случайное число в диапазоне от 1 до 1000), которое т
угадать. Далее программа печатает:
У меня есть число между 1 и 1000 Отгадайте и введите ваше число ...
Далее игрок вводит первое число. Программа соответствует одной из фраз:
Прекрасно! Вы угадали число! Будете играть дальше?
Слишком мало. Попробуйте еще раз.
Слишком велико. Попробуйте еще раз.
При реализации игры необходимо написать функцию, которая принимает два числа:
"Задуманное" и ответ игрока, а после анализа печатать одну из фраз.
Вот код но мне нужно с функции переделать.
#include
#include
#include
#include
#include
using namespace std;
void main()
{
setlocale(LC_CTYPE, "ukr");
srand(unsigned(time(NULL)));
int a, b, i;
a = rand() % 1000 + 1;
printf( "Гра \"Вгадай число\".\n\n");
printf( "У мене є число між 1 та 1000.\n");
printf( "Відгадайте і введіть ваше число\n\n");
for (i = 1; i < 100; i++)
{
printf( "--->");
scanf_s("%d",&b);
if (b == a)
{
printf("Чудово! Ви вгадали число! Будете грати далі?\n");
printf("Ви вгадали число з %d попитки!\n",i);
break;
}
if (b > a)
{
printf("Занадто велике. Спробуйте ще раз.\n");
}
if (b < a)
{
printf("Занадто мале. Спробуйте ще раз.\n");
}
}
if (b != a && i == 100)
{
printf("Нажаль ви так і не вгадали число ");
printf("\n");
}
}

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Katerinkacat
25.05.2023 18:05

P =NP

Объяснение:

создаем переменую х и у

и содаем перемную х 1 и  у1

P равно х и игрек

NP равно х 1 и  у1

теперь P =NP

проверяем в системе кординат например 8 на 8

мы видим равенство класов

смотри мы можем сделать так

допустим это книга с пронумероваными страницами

каждая страница собщаеть какой диапазон значение на даном поле

но если мы будем сравнивать первая клетка и каждую последущую перебором это будет  долго

мы можем наложить поле на поле   и проверить сразу два значения  и сравнить их отельно

то есть  найдя на страничке  список номеровмы можем сразу  выводить значения из поля  и передать еще одной переменой проверить  были совпадения или нет

0,0(0 оценок)
Ответ:
Урок541
14.06.2022 01:51

Зачем нужны программы распознавания текста.

С их выполняется редактирование информации, исправление ошибок, сохранение данных в нужном формате и т.

Как происходит распознавание текста?

Поэтапное сканирование и распознавание текста. ... Далее происходит проверка на предмет синтаксических и орфографических ошибок

Какие программы распознавание текста вы знаете?

Они с легкостью переведут pdf, jpg, png или «бумажный файл» в редактируемый формат для Word и прочих офисных приложений.

ABBYY FineReader.

OCR CuneiForm.

Readiris Pro.

Freemore OCR.

ABBYY Screenshot Reader.

Adobe Acrobat Pro.

Scanitto Pro.

RiDoc.

Какими пользовались?

ABBYY FineReader.

OCR CuneiForm.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота