airmenplay
28.02.2022 02:40

1. Написать программу, которая вводит двумерный массив 3х3, выводит его на экран в виде матрицы, а затем выводит количество элементов меньше 5, но больше 0. 6 3 9
5 9 2
3 7 6

Количество элементов меньше пяти, но больше нуля равно 3.

2. Мальчик купил несколько тетрадей по сто рублей и несколько обложек по 50 рублей. Составить программу, которая могла бы подсчитать стоимость всей покупки.
Это паскаль

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
poshel0naher
16.07.2021 17:32

1)

const

 n=3;

var

 a:array [1..n,1..n] of integer;

 i,j,count:integer;

begin

 count:=0;

 for i:=1 to n do

   begin

     for j:=1 to n do

       begin

         a[i,j]:=random(21)-10;

         write(a[i,j]:4);

         if (a[i,j] < 5) and (a[i,j] > 0) then

           inc(count);

       end;

     writeln;

   end;

 writeln('Количество элементов меньше пяти, но больше нуля равно ',count);

end.

2)

var

 t,o:integer;

begin

 write('Купленное количество тетрадей: '); readln(t);

 write('Купленное количество обложек: '); readln(o);

 t:=t*100; o:=o*50;

 writeln('Итоговая сумма покупки: ',t+o)

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота