Lizamog1
19.04.2022 05:53

Дана дробь вида . Нужно написать программу, проверяющую, является ли дробь правильной или нет

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ераврлга
24.04.2021 22:33
Using System;

public class Test
{
    public static void Main()
    {
        Console.Write("Введите координату х исходной точки (1-8): ");
        int x1=Convert.ToInt32(Console.ReadLine());
        Console.Write("Введите координату y исходной точки (1-8): ");
        int y1=Convert.ToInt32(Console.ReadLine());
        Console.Write("Введите координату х нужной точки (1-8): ");
        int x=Convert.ToInt32(Console.ReadLine());
        Console.Write("Введите координату y нужной точки (1-8): ");
        int y=Convert.ToInt32(Console.ReadLine());
        bool r=(Math.Abs(x-x1)*Math.Abs(y-y1)==2) &&
            (x>0) && (x1>0) && (x<9) && (x1<9) &&
            (y>0) && (y1>0) && (y<9) && (y1<9);
        Console.WriteLine(r);
    }
}

Непосредственно условие:
(Math.Abs(x-x1)*Math.Abs(y-y1)==2) &&
      (x>0) && (x1>0) && (x<9) && (x1<9) &&
      (y>0) && (y1>0) && (y<9) && (y1<9)

На шахматной доске с координатами x1 и y1 находится фигура конь: запишите условие (логическое выраже
0,0(0 оценок)
Ответ:
александра7896
09.08.2022 21:46
Вот решение на C#
using System;
using System.Collections.Generic;
using System.Linq;

namespace Help
{ 

    class MainClass
    {
        public static void Main(string[] args)
        {
            int day = 1;
            double mass = 50;
            double changing = 1.2;
            
            while(mass < 120)
            {
                mass *= changing;
                day++;                
            }
            
            Console.WriteLine($"В {day} день");
        }
    }
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота