leogorec06
14.08.2020 08:57

С++ Похожие массивы
Назовём два массива похожими, если они состоят из одних и тех же элементов (без учёта кратности). По двум данным массивам выясните, похожие они или нет.

Входные данные

В первой строке содержится число N(1≤N≤100000) — размер первого массива. Во второй строке идут N целых чисел, не превосходящих по модулю 109, — элементы массива. Далее аналогично задаётся второй массив.

Выходные данные

Программа должна вывести слово YES, если массивы похожи, и слово NO в противном случае.

Примеры
Ввод
Вывод
3
1 7 9
4
9 7 7 1

YES

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
alsav241357
05.08.2021 10:47

Здравствуйте

#include <set>

#include <iostream>

#include <iterator>

#include <algorithm>

using namespace std;

int main()

{

   set<int> a,b;

   size_t n;

   cin >> n;

   copy_n(istream_iterator<int>(cin),n,inserter(a,a.end()));

   cin >> n;

   copy_n(istream_iterator<int>(cin),n,inserter(b,b.end()));

   cout << ((a==b)? "YES" : "NO") << endl;

}

Объяснение:

Тест успешно пройден

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота