Аня5сплюсом
31.08.2021 10:02

1)(паскаль) дан целочисленный массив из 30 элементов. элементы массива могут принимать целые значения от 0 до 100 – учащихся выпускного класса за итоговый тест по информатике. напишите программу, которая находит и выводит номера двух соседних элементов массива, сумма которых минимальна. исходные данные объявлены так, как показано ниже. запрещается использовать переменные, не описанные ниже, но разрешается не использовать часть из них. const n=30; var a: array [1..n] of integer; i, j, min, min2, s: integer; begin for i: =1 to n do readln(a[i]); end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
соникна
23.06.2020 20:15
Использовал две переменные из пяти возможных.

const N=30;
var a: array [1..N] of integer;
i,j:integer;
begin
for i:=1 to N do read(a[i]);
j:=1;
for i:=1 to N-1 do if a[i]+a[i+1]<a[j]+a[j+1] then j:=i;
write(j,' ',j+1)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота