diasdias2000
30.01.2021 02:58

Напишите программу, которая будет запрашивать у пользователя число N, генерировать N случайных чисел в диапазоне от 1 до 50, для каждого
сгенерированного случайного числа вычислять сумму от 1 до этого числа и
печатать табличку чисел и сумм. Программа на питоне

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kykapeka227
25.08.2021 18:52

Объяснение:

Python

from random import randint

def getsum(a):

   s=0

   for i in range (1,a+1):

      s+=i

   return s    

n=int(input('Введите n: '))

a=[randint(1,50) for i in range(n)]

for i in range (0, n):

  print(a[i], ' сумма =',getsum(a[i]))


Напишите программу, которая будет запрашивать у пользователя число N, генерировать N случайных чисел
0,0(0 оценок)
Ответ:
NastiaForever18
25.08.2021 18:52

Объяснение:

В конце всё ужасно некрасиво получилось, но я начинающий, так что таблицы еще знать не знаю.

Если что-то непонятно, пиши


Напишите программу, которая будет запрашивать у пользователя число N, генерировать N случайных чисел
Напишите программу, которая будет запрашивать у пользователя число N, генерировать N случайных чисел
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота