тай4
17.02.2021 11:10

На языке джава. Написать программу, в результате которой считается сумма элементов целочисленного массива с циклов for, while, do while, результат выводится на экран.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nastyarybinskap0ai9q
25.11.2021 06:55

//С циклом for:

import java.util.Scanner;

import java.util.Arrays; //Если захочется напечатать в консоль массив

public class MyClass {

   public static void main(String args[]) {

       Scanner input = new Scanner(System.in);

       String[] numbers = input.nextLine().split(" "); /split() делит значения после определённого символа, в нашем случае — пробела

       int sum = 0;

   

       for(int i = 0; i<numbers.length; i++) {

           sum += Integer.parseInt(numbers[i]);

       }

       System.out.println("The sum of the numbers: " + sum);

       //System.out.println(Arrays.toString(numbers));

   }

}

//С циклом while:

import java.util.Scanner;

import java.util.Arrays;

public class MyClass {

   public static void main(String args[]) {

       Scanner input = new Scanner(System.in);

       String[] numbers = input.nextLine().split(" ");

       int sum = 0;

       int i = 0;

 

       while(numbers.length != i) {

              sum += Integer.parseInt(numbers[i]);

              i++;

       }

       System.out.println("The sum of the numbers: " + sum);

       //System.out.println(Arrays.toString(numbers));

   }

}

//С циклом do-while:

import java.util.Scanner;

import java.util.Arrays;

public class MyClass {

   public static void main(String args[]) {

       Scanner input = new Scanner(System.in);

       String[] numbers = input.nextLine().split(" ");

       int sum = 0;

       int i = 0;

       

       do {

           sum += Integer.parseInt(numbers[i]);

           i++;

       } while(numbers.length != i);

       

       System.out.println("The sum of the numbers: " + sum);

       //System.out.println(Arrays.toString(numbers));

   }

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота