ира8800
24.04.2021 01:11

Составить программу определяющую сколько чисел делящихся на 3 в последовательности из 20 чисел

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
жанара06
28.05.2022 13:19
Символ-это набор команд состоящих из единиц и нулей,любое слово вводимое тобой или выведонное тебе состоит из этих последовательностей. Например символ I (Я) зашифрован так 0100 1001 <-- 8 этих битов образуют 1 символ,называемым байтом,поэтому любой текст,изображение,видео(там немного другая схема действует),все это всего лишь грандиозный набор команд,разговоры по телефону тоже кодируются из вибрации в набор импульсов и на обратном выходе опять преобразуются в нам всем привычные слова.Любые механизмы,и даже мы с Вами можем передавать информацию,в том числе Азбукой Морзе,даже несколько последовательно сформулированных щелчков пальцев несут в себе информацию,главное ее понять,расшифровать и преобразовать,в видео,аудио,текст,фотографию.
0,0(0 оценок)
Ответ:
bashkirovarima
04.10.2020 00:15
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  var n:=ReadInteger('n=');
  var a:=MatrixRandom(n,n,10,99);
  var s:=0;
  var k:=0;
  for var i:=0 to n-1 do begin
    for var j:=0 to n-1 do Print(a[i,j]);
    Writeln;
    if a[i,i].IsEven then begin s+=a[i,i]; Inc(k) end;
    end;
  if k>0 then Writeln('S=',s/k:0:2)
  else Writeln('На главной диагонали нет четных элементов')
end.

Тестовое решение
n= 8
63 13 33 90 25 21 87 91
88 88 48 13 30 59 81 27
73 23 76 77 52 19 33 97
53 87 13 74 17 35 61 70
77 96 51 61 82 33 63 22
39 88 84 54 88 73 74 69
76 26 69 14 45 80 70 54
80 36 47 38 18 22 84 62
S=75.33
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота