ddd114
24.04.2021 07:24

задание на фото Номер 10. надо написать программу В ПАСКАЛЕ, сначала найти значения, а потом сравнить. Сравнить то я смогу сам, а вот значения a,b,c узнать не могу


задание на фото Номер 10. надо написать программу В ПАСКАЛЕ, сначала найти значения, а потом сравнит

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
upvchasro
26.11.2021 02:51

ответы программы (наименьшее значение из трёх):

1) 0.0828638516274247

2) 0.164832693219929

3) 0.145644125326545

Два текста программы (отличия во вводе икс и нахождения наименьшего):

var

x,a,b,c: real;

begin

write('x= ');

read(x);

a:=Exp(Power(Sin(x),2));

b:=1+Exp(Abs(x))/(1+Ln(Abs(Power(x,1/3;

c:=Tan(x/2)/(2+0.8*Power(x,4));

writeln('a= ',a);

writeln('b= ',b);

writeln('c= ',c);

write('min= ');

if a<b then

if a<c then write(a) else write(c)

else

if b<c then write(b) else write(c);

end.

var x,a,b,c: real;

begin

x:=ReadReal('x=');

a:=Exp(Power(Sin(x),2));

b:=1+Exp(Abs(x))/(1+Ln(Abs(Power(x,1/3;

c:=Tan(x/2)/(2+0.8*Power(x,4));

writeln('a= ',a);

writeln('b= ',b);

writeln('c= ',c);

write('min= ',Min(Min(a,b),c));

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота