mixpix
03.08.2020 15:56

Паскаль . Напишите программу, которая в последовательности целых чисел определяет сумму двух наибольших и сумму двух наименьших. Программа должна вывести две этих суммы в указанном порядке. Программа получает на вход целые числа, количество введённых чисел не известно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:

var

 a,c1,c2,s1,s2:integer;

begin

 readln(a);

 if a=0 then  

   begin

     writeln('Error');

     exit;

   end;

 s2:=-30000; c2:=30000;

 s1:=-30000; c1:=30000;

 repeat

   if (a>s1) or (a>s2) then

     if s1>s2 then

       s2:=a  

     else

       s1:=a;

   if (a<c1) or (a<c2) then

     if c1>c2 then

       c1:=a

     else

       c2:=a;

   readln(a);

 until a=0;

 writeln('max: ',s1+s2);

 writeln('min: ',c1+c2);

end.

Если моё решение вам, пометьте его лучшим !

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота