huifufjvJf
24.05.2020 12:10

Напишите программу на pascalabc, которая решает это математическое выражение .


Напишите программу на pascalabc, которая решает это математическое выражение .

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Элизабет3000000
28.02.2023 17:13

31

Объяснение:

/** libraries */

#include <iostream>

#include <cmath>

#include <vector>

#include <map>

#include <set>

#include <queue>

#include <stack>

#include <algorithm>

/** libraries */

using namespace std;

/** defines */

#define ll long long

#define ld long double

#define yes cout << "YES" << "\n"

#define no cout << "NO" << "\n"

/** defines */

ll to_10(ll num){

   ll i = 0,res = 0;

   while(num > 0){

       res += pow(2,i) * (num % 10);

       num /= 10;

       i++;

   }

   return res;

}

signed main() {

   ios_base::sync_with_stdio(false);

   cin.tie(nullptr);

   cout.tie(nullptr);

   for(ll x = -1000000; x <= 1000000; x++){

       if(x - to_10(11110) > 0&&to_10(11) * to_10(1001) - sqrt((to_10(101011) + to_10(111001))/(x-to_10(11110))) == to_10(10001)){

           cout << x;

           return 0;

       }

   }

}

0,0(0 оценок)
Ответ:
Рита460
28.02.2023 17:13

31

Объяснение:

/** libraries */

#include <iostream>

#include <cmath>

#include <vector>

#include <map>

#include <set>

#include <queue>

#include <stack>

#include <algorithm>

/** libraries */

using namespace std;

/** defines */

#define ll long long

#define ld long double

#define yes cout << "YES" << "\n"

#define no cout << "NO" << "\n"

/** defines */

ll to_10(ll num){

   ll i = 0,res = 0;

   while(num > 0){

       res += pow(2,i) * (num % 10);

       num /= 10;

       i++;

   }

   return res;

}

signed main() {

   ios_base::sync_with_stdio(false);

   cin.tie(nullptr);

   cout.tie(nullptr);

   for(ll x = -1000000; x <= 1000000; x++){

       if(x - to_10(11110) > 0&&to_10(11) * to_10(1001) - sqrt((to_10(101011) + to_10(111001))/(x-to_10(11110))) == to_10(10001)){

           cout << x;

           return 0;

       }

   }

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота