krit3
31.03.2020 06:27

Написать программу в паскале, которая после введенного с клавиатуры числа(в диапазоне от 1 до 99), обозначающий денежную единицу, дописывал слово "копейка". например ,5 копеек,41 копейка и тд. вот мои попытки создать программу: program kopeika; var a: integer; begin writeln('vvedite chislo'); readln(a); case a of '1,21,31,41,51,61,71,81,91': a: ='kopeika '; '2..4,22..24,32..34,42..44,52..54,62..64,72..74,82..84,92..94': a: ='kopeiki '; '5..20,25..30,35..40,45..50,55..60,65..70,75..80,85..90,95..99': a: =' kopeek'; end; readln; end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Даниил12345666
24.06.2020 22:59
По идее нужен цикл, который будет перебирать значения case. Я больше знаю c#, но могу посоветовать только поработать с циклами, т.к не знаю как с ними обстоит дело в паскале.
0,0(0 оценок)
Ответ:
oksukbaevak
24.06.2020 22:59
Исправленный вариант:
program Kopeika;
var
  a: integer;
begin
  Writeln('Vvedite chislo');
  Readln(a);
  case a of 
   1, 21, 31, 41, 51, 61, 71, 81, 91: write(a, ' kopeika');
   2..4, 22..24, 32..34, 42..44, 52..54, 62..64, 72..74, 82..84, 92..94: write(a, ' kopeiki');
   5..20, 25..30, 35..40, 45..50, 55..60, 65..70, 75..80, 85..90, 95..99: write(a, ' kopeek');
  end;
  Readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота