JloJlKeK
30.01.2021 04:31

Написать программу на фортране Заменить все отрицательные элементы массива на
первый положительный элемент (например, -1 -2 6 -36 0 -4 9 -7 ... — здесь первым
положительным элементом является число 6). Вывести измененный массив в том
же виде что и исходный, но со следующей строки.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
EM20011
11.08.2020 22:34
Для облегчения выкладок разделим эти 64 множителя на шесть групп по 10 двоек в каждой и одну последнюю группу из четырех двоек. Произведение 10 двоек, как легко убедиться, равно 1024, а четырех двоек— 16. Значит, искомый результат равен 1024 X 1024 X 1024 X 1024 X 1024 X 1024 X 16.Перемножив 1024 X 1024, получим 1 048 576.Теперь остается найти 1048 576X1048 576X1048 576X16, отнять от результата единицу — и нам станет известно искомое число зерен: 18 446 744 073 709 551615. Известно, что кубический метр пшеницы вмещает около 15 миллионов зерен. Значит, награда шахматного изобретателя должна была бы занять объем примерно в 12 000 000 000 000 куб. м. Кстати, это геометрическая прогрессия и ее нужно было кидать в раздел "математика".
0,0(0 оценок)
Ответ:
SvetaCat115
19.09.2022 23:32
//Сделал Лугачев Кирилл
//Специально для
//Все данные вводятся с клавиатуры
program Sravnenie;
var   
a, b: integer; // Стороны 1-ого прямоугольника 
d, c: integer;// Стороны 2-ого прямоугольника 
S1, S2: integer; // Площадь 
buf: integer;// Если площадь 1-ого будет меньше 2-ого                
                   //поменяем местами,что бы избавиться от минуса 
razn: integer; // Разница 2-ух площадей

begin   
Write('Введите стороны 1-ого прямоугольника: '); 
Readln(a, b);
   
Write('Введите стороны 2-ого прямоугольника: '); 
Readln(d, c);   
S1 := a * b; //Площадь 1-ого 
S2 := d * c; //Площадь 2-ого   
if S1 < S2 then  
begin   
buf := S1;   
S1 := S2;   
S2 := buf; 
end;   
razn := S1 - S2;    
Writeln('Площадь 1-ого больше площади 2-ого в - ',razn, ' раз');  
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота